TrabalhosGratuitos.com - Trabalhos, Monografias, Artigos, Exames, Resumos de livros, Dissertações
Pesquisar

1Рseudo-código : Conversão das 4 moedas para as 4 moeda

Por:   •  7/4/2013  •  Abstract  •  396 Palavras (2 Páginas)  •  596 Visualizações

Página 1 de 2

'1PSEUDO-CÓDIGO : Conversão das 4 moedas para as 4 moedas.

inicio

real: moeda_real, valor_dolar, dolar, valor_dolarcnd, dolar_cnd, valor_euro, euro, real_euro, real_dolar, real_dolarcnd;

inteiro: escolha1, escolha2;

valor_dolar = 1.94;

valor_dolarcnd = 1.80;

valor_euro = 2.16;

real_euro = 2.16;

real_dolar = 1.94;

real_dolarcnd = 1.80;

escreva ("Programa que converte moedas...");

escreva ("Deseja Converter qual moeda ?");

escreva ("Pressione: 1 - Real, 2 - Dolar, 3 - Dolar Canadense, 4 - Euro");

leia(escolha1);

se (escolha1==1)

então;

inicio;

escreva ("Voce escolheu converter Real !!!");

escreva ("Deseja Converter a moeda Real para qual moeda ?");

escreva ("1 - Dolar, 2 - Dolar Canadense, 3 - Euro: ");

leia (escolha2);

fim;

se (escolha2==1)

então;

inicio;

escreva("Voce decidiu converter da moeda Real para Dolar !");

escreva("Insira o valor em Reais: ");

leia(moeda_real);

dolar = moeda_real * valor_dolar;

escreva ("Esse valor em Reais equivalem a Dolares.",dolar);

fim;

fim se;

se (escolha2==2)

então;

inicio

escreva("Voce decidiu converter da moeda Real para Dolar Canadense");

escreva("Insira o valor em Reais: ");

leia(moeda_real);

dolar_cnd = moeda_real * valor_dolarcnd;

escreva ("Esse valor em Reais equivalem a Dolares Canadense.",dolar_cnd);

fim;

fim se;

se (escolha2==3)

então;

inicio;

escreva("Voce decidiu converter da moeda Real para Euro !");

escreva("Insira o valor em Reais: ");

leia(moeda_real);

euro = moeda_real * valor_euro;

escreva ("Esse valor em Reais equivalem a Euros",euro);

fim;

fim se;

fim se;

senão se(escolha1==2)

então;

inicio;

escreva("Você escolheu converter em Dolar !!!");

escreva("Deseja converter a moeda Dolar para qual moeda ?");

escreva("Pressione: 2 - Dolar Canadense, 3 - Euro, 4 - Real: ");

leia(escolha2);

fim;

se (escolha2==2)

então;

inicio;

escreva("Voce decidiu converter da moeda Dolar para Dolar Canadense !");

escreva("Insira o valor em Dolares: ");

leia(dolar);

dolar_cnd = dolar / valor_dolarcnd;

escreva("Esse valor em Dolares equivalem a Dolares Canadense.",dolar_cnd);

fim;

...

Baixar como (para membros premium)  txt (3.8 Kb)  
Continuar por mais 1 página »
Disponível apenas no TrabalhosGratuitos.com