TrabalhosGratuitos.com - Trabalhos, Monografias, Artigos, Exames, Resumos de livros, Dissertações
Pesquisar

Logica e Algoritmos

Por:   •  5/6/2015  •  Projeto de pesquisa  •  505 Palavras (3 Páginas)  •  142 Visualizações

Página 1 de 3

5. Fazer o algoritmo que leia os quocientes de uma equação do 1º grau, calculem e mostrem a sua raiz. OBS: Equação do 1º grau → ax + b (a <> 0)

Programa Calculo

Inicio

var N1, N2, Resul : real;

Leia N1, N2

Se N1 <> 0 então

Resul ← (N2 – N1) // Onde: x = b - a

escreva: ( “O resultado é : ”, Resul )

senão

escreva: ( “ Valor de ”, N1 ,“inválido”);

fimse

Fim

14. Fazer o algoritmo que leia 4 notas de um aluno, calculem e exibam a média aritmética das notas e a mensagem “Aprovado” para média superior ou igual a 7, ou a mensagem “Reprovado” para média inferior a 7.

Programa Media

Inicio

var N1, N2, N3, N4, media : real

Leia N1, N2, N3, N4

media ← ( N1 + N2 + N3 + N4) / 4

Se media >= 7 então

Escreva: ( “Média: ”, media “Aprovado”)

senão

Escreva ( “Média: ”, media “Reprovado”)

Fimse

Fim

2. Elabore um algoritmo que leia uma serie de 50 alunos, e calcule quantos são 10% acima da media e quantos são 10% abaixo da media. Media = 7

Programa Media_Alunos

Inicio

tipo Vm = Vetor [ 1..50] de reais;

Vm = VetMed

Real : Malta, Mbaixa, CONT

para CONT de 1 até 50 faça

Leia Vetmed[CONT]

Se Vetmed[CONT] >= 7 então

Malta ← Malta + 1

** Formula de porcentagem dos 50 alunos

Escreva (“Alunos acima da Media” , Malta);

senão

Mbaixa ← Mbaixa + 1

** Formula de porcentagem dos 50 alunos

Escreva (“Alunos abaixo da Media” , Mbaixa);

fimse

fimpara

fim

19. Fazer o algoritmo

...

Baixar como (para membros premium)  txt (2.4 Kb)   pdf (43.9 Kb)   docx (570.4 Kb)  
Continuar por mais 2 páginas »
Disponível apenas no TrabalhosGratuitos.com