TrabalhosGratuitos.com - Trabalhos, Monografias, Artigos, Exames, Resumos de livros, Dissertações
Pesquisar

Exercício algoritmo "consumo"

Por:   •  12/6/2012  •  Trabalho acadêmico  •  855 Palavras (4 Páginas)  •  753 Visualizações

Página 1 de 4

2 DESENVOLVIMENTO

2.1 Exercício 1

algoritmo "consumo"

// Função : calcula o consumo médio de combustível

// Data : 25/5/2011

// Seção de Declarações

var

DIST, VOL, CM: real

inicio

// Seção de Comandos

escreval("Algoritmo para calcular o consumo")

escreval("Distância total percorrida (km):")

leia(DIST)

escreval("Volume de combustível gasto (L):")

leia(VOL)

CM <- DIST/VOL

escreval("Consumo médio= ", CM, "km/l")

fimalgoritmo

2.2 Exercício 2

algoritmo "inss"

// Função : Calcula o percentual de desconto de um salário junto ao INSS

// Data : 24/5/2011

// Exercício 2

// Seção de Declarações

var

FUNC : caracter

SAL_BR, DESC : real

inicio

// Seção de Comandos

escreval("Cálculo de desconto INSS - Entrada de dados")

escreva("Nome do funcionário: ")

leia(FUNC)

escreva("Salário bruto: ")

leia(SAL_BR)

// calcula o valor do desconto

se (SAL_BR > 1000) entao

DESC <- (SAL_BR * 0.11)

senao

DESC <- (SAL_BR * 0.09)

fimse

// limpa a tela e exibe os dados calculados

limpatela

escreval("Cálculo de desconto INSS")

escreval("Nome do funcionário: ", FUNC)

escreval("Salário Bruto .... : R$ ", SAL_BR:8:2)

escreval("Salário Líquido .. : R$ ", (SAL_BR - DESC):8:2)

// escreval("Desconto INSS .....: R$ ", DESC:8:2)

fimalgoritmo

2.3 Exercício 3

algoritmo "Desconto Compra"

// Função : calcula o desconto ao cliente pelo do valor total da compra

// Data : 25/5/2011

// Seção de Declarações

var

valor_total, valor_desc : real

cliente : caracter

inicio

// Seção de Comandos

escreval ("Nome do Cliente:")

leia (cliente)

escreval ("Valor total da compra:")

leia (valor_total)

se valor_total < 1000 entao

(valor_desc 1000) e (valor_total < 5000) entao

valor_desc <- (valor_total *10)/100

senao

valor_desc <- (valor_total*15)/100

fimse

escreval ("Cliente: ", cliente)

escreval ("Valor do desconto: R$ ", valor_desc:8:2)

fimalgoritmo

2.4 Exercício

...

Baixar como (para membros premium)  txt (5 Kb)  
Continuar por mais 3 páginas »
Disponível apenas no TrabalhosGratuitos.com