TrabalhosGratuitos.com - Trabalhos, Monografias, Artigos, Exames, Resumos de livros, Dissertações
Pesquisar

Lnformatica Aplicada A Engenharia

Artigos Científicos: Lnformatica Aplicada A Engenharia. Pesquise 812.000+ trabalhos acadêmicos

Por:   •  6/10/2013  •  493 Palavras (2 Páginas)  •  1.066 Visualizações

Página 1 de 2

ALGORITMO 01

Construa um algoritmo que leia a quantidade (Q) e o preço (PR) de vários produtos diferentes, comprados por uma empresa, e apresente o total gasto por ela. O final da lista de produtos deverá ser indicado pelo usuário (escolha a maneira que preferir).

OBS: Não se esqueça de validar a entrada dos valores, pois não são aceitas quantidades negativas, nem preços negativos.

algoritmo "semnome"

// Função :

// Autor :

// Data : 6/10/2013

// Seção de Declarações

var

q, pr, I, acumulador: real

inicio

para I de 1 ate 45 faca

escreva('Informe a quantidade:');

leia(q);

escreva("informe o preço de cada unidade:");

acumulador:= (q * pr)

fimpara

escreva('total gasto:' , "acumulador")

fimalgoritmo

ALGORITMO 02

Uma certa firma fez uma pesquisa de mercado para saber se as pessoas gostaram ou não de um novo produto lançado. Para isso forneceu o sexo do entrevistado e sua resposta (sim ou não). Sabendo que foram entrevistadas 10 pessoas, faça um algoritmo que calcule e imprima:

• número de pessoas que responderam sim;

• número de pessoas que responderam não;

• número de mulheres que responderam sim;

• a porcentagem de homens que responderam não entre todos os homens analisados.

ALGORITMO 03

Supondo que a população de um país A seja da ordem de 9.000 habitantes com uma taxa anual de crescimento de 3% e que a população de um país B seja, aproximadamente, de 20.000 habitantes com taxa anual de crescimento de 1.5%, fazer um algoritmo que calcule e escreva o número de anos necessários para que a população do país A ultrapasse ou se iguale à população do país B, mantidas estas taxas de crescimento.

ALGORITMO 04

Elabore um algoritmo que determine o valor de S, onde:

S = 1/1 - 2/4 + 3/9 - 4/16 + 5/25 - 6/36 ... - 10/100.

ALGORITMO 05

Elabore um algoritmo para ler a altura e o sexo (masculino ou feminino) de 10 (dez) pessoas. Calcular e mostrar:

- a maior e a menor altura do grupo

- a média de altura das mulheres

- o número de homens (quantos homens)

- a porcentagem de mulheres (em relação ao nº total de pessoas)

ALGORITMO 06

Foi

...

Baixar como (para membros premium)  txt (3.1 Kb)  
Continuar por mais 1 página »
Disponível apenas no TrabalhosGratuitos.com