TrabalhosGratuitos.com - Trabalhos, Monografias, Artigos, Exames, Resumos de livros, Dissertações
Pesquisar

Redes Computadores

Casos: Redes Computadores. Pesquise 788.000+ trabalhos acadêmicos

Por:   •  20/11/2014  •  310 Palavras (2 Páginas)  •  582 Visualizações

Página 1 de 2

var

pessoas: vetor[1..1000] de inteiro

N, M, i, j, k, l: inteiro

inicio

escreva("Informe o número de pessoas (no máximo 1000): ")

leia(N)

escreva("Informe o valor de M: ")

leia (M)

enquanto (M > N) faca

escreva("Valor inválido. Reinforme o valor de M: ")

leia (M)

fimenquanto

para i de 1 ate N faca

pessoas[i] <- i

fimpara

k <- 0

l <- 1

enquanto (k < N) faca

j <- 0

enquanto (j < M) faca

enquanto (pessoas[l] < 0) faca

se (l = N) entao

l <- 1

senao

l <- l + 1

fimse

fimenquanto

j <- j + 1

fimenquanto

escreval("Ordem: ", k, " - pessoa: ", l)

pessoas[l] <- -l

k <- k + 1

fimenquanto

...

Baixar como (para membros premium)  txt (837 bytes)  
Continuar por mais 1 página »
Disponível apenas no TrabalhosGratuitos.com