TrabalhosGratuitos.com - Trabalhos, Monografias, Artigos, Exames, Resumos de livros, Dissertações
Pesquisar

Algoritmo "INDICAÇÃO DE IDADE EM DIAS"

Resenha: Algoritmo "INDICAÇÃO DE IDADE EM DIAS". Pesquise 787.000+ trabalhos acadêmicos

Por:   •  6/10/2014  •  Resenha  •  334 Palavras (2 Páginas)  •  334 Visualizações

Página 1 de 2

1) Faça um algoritmo que leia a idade de uma pessoa expressa em anos, meses e dias e apresente na tela tal idade apenas em dias. Considere que um mês possui trinta dias, e um ano possui trezentos e sessenta e cinco dias.

Algoritmo " INDICAÇÃO DA IDADE EM DIAS "

// Função : CALCULAR IDADE EM DIAS A PARTIRDE ANOS,MESES E DIAS APONTADOS

// Seção de Declarações

var

anos: inteiro

meses: inteiro

dias: inteiro

inicio

escreva("Informe quantos anos você tem: ")

leia(anos)

se ( anos < 1 )então

escreva( " OK..... , mas vamos la: " )

fimse

se(anos >0 ) entao

fimse

escreva("Informe quantos meses você tem: " )

leia(meses)

escreva("Informe quantos dias você tem: ")

leia(dias){calculo da idade}

escreva("Você tem ", (anos*365)+(meses*30)+(dias*1), " dias de idade ")

fimalgoritmo

2) Elabore um algoritmo capaz de calcular a distancia entre dois pontos em um espaço euclidiano. Para tanto, considere a seguinte formula: dist = raiz quadrada ( (x2-x1)² + (y2-y1)² ).

Algoritmo " MEDICAO DE DISTANCIA "

// Função : Calculo de distancia Euclidiana

//Seção de Declarações

var

x1,x2,y1,y2:real

distancia: real

inicio// Seção de Comandos

escreva("Informe os pontos 1 x/y: ")

leia(x1,y1)

escreva("Informe os pontos 2 x/y: ")leia(x2,y2)

escreva(" DISTANCIA = ",( (( x2-x1)^2) + (y2-y1)^2)^(1/2))

fimalgoritmo

3) Construa um algoritmo capaz de ler três números positivos (X, Y, Z) e calcule a seguinte expressão: E = (A + B) ∕ 2, em que A = (X + Y)², e B = (Y + Z)².

Algoritmo “Algoritmo capaz de ler tr~es números positivos, calculando expressões”

//Declaração de variáveis

Var

X, Y, Z: inteiro

Expressão, funcaoA, funcaoB: real

Inicio

//Seção de comandos

Escreva(“digite o primeiro numero: “)

Leia (X)

Escreva(“digite

...

Baixar como (para membros premium)  txt (2.5 Kb)  
Continuar por mais 1 página »
Disponível apenas no TrabalhosGratuitos.com