TrabalhosGratuitos.com - Trabalhos, Monografias, Artigos, Exames, Resumos de livros, Dissertações
Pesquisar

Algrítmos - Sequencial Estrutural

Por:   •  6/3/2013  •  554 Palavras (3 Páginas)  •  716 Visualizações

Página 1 de 3

Respostas: Algoritmos - Estrutura Sequêncial - Exercícios Avaliativos

1.

algoritmo "Raiz quadrada de um número"

// Função : Mostrar Raiz Quadrada de um número

// Autor : Gustavo Santos Arruda

// Data : 05/03/2013

// Seção de Declarações

var

valor: Inteiro

resultado: Real

inicio

// Seção de Comandos

Escreval("Digite um número:")

Leia(valor)

Se valor < 0 entao

Escreval("O valor digitado não pode ser negativo!")

Senao

resultado <- valor ^ (1/2)

Escreval("A raiz quadrada do valor digitado é: ", resultado)

Fimse

Fimalgoritmo

2.

algoritmo "Área de um triângulo"

// Função : Calcular a área de um triângulo

// Autor : Gustavo Santos Arruda

// Data : 05/03/2013

// Seção de Declarações

var

base: Inteiro

altura: Real

resultado: Real

area: Real

inicio

// Seção de Comandos

Escreval("Digite o valor da base do triângulo:")

Leia(base)

Escreval("Digite o valor da altura do triângulo:")

Leia(altura)

resultado <- (base*altura) / 2

Escreva("A área do triângulo é de: ", resultado)

fimalgoritmo

3.

algoritmo "Converte temperatura"

// Função : Converte uma temperatura em Cº para Fº

// Autor : Gustavo Santos Arruda

// Data : 05/03/2013

// Seção de Declarações

var

celcuis, fahrenheit: Real

inicio

// Seção de Comandos

Escreval("Digite a temperatura em Cº:")

Leia(celcuis)

fahrenheit <- celcuis * 1.8 + 32

Escreval("A temperatura em Fº é: ", fahrenheit,"Fº")

fimalgoritmo

4.

algoritmo "Calcula ângulo"

// Função : Mostra os ângulos de um triângulo

// Autor : Gustavo Santos Arruda

// Data : 05/03/2013

// Seção de Declarações

var

v, x, y, r, resultado: inteiro

inicio

// Seção de Comandos

Escreval("Digite o valor do primeiro ângulo:")

Leia(x)

Escreval("Digite o valor do

...

Baixar como (para membros premium)  txt (3.7 Kb)  
Continuar por mais 2 páginas »
Disponível apenas no TrabalhosGratuitos.com