TrabalhosGratuitos.com - Trabalhos, Monografias, Artigos, Exames, Resumos de livros, Dissertações
Pesquisar

Tabela Verdade Sensor Alarme

Tese: Tabela Verdade Sensor Alarme. Pesquise 798.000+ trabalhos acadêmicos

Por:   •  9/5/2013  •  Tese  •  3.880 Palavras (16 Páginas)  •  560 Visualizações

Página 1 de 16

SUMÁRIO

4.1- Tabela Verdade Sensor Alarme...................................................04.

4.2- Algoritmo Locação de Livro.........................................................05.

4.3- Tabela Verdade T(p,q,r)..............................................................06.

2 INTRODUÇÃO

Esse trabalho tem por objetivo demostrar através de um cenário proposto um a resolução de atividades propostas.

TABELA VERDADE SENSOR ALARME

Detector1 Detector2 Alarme

0 0 0

0 1 1

1 0 1

1 1 1

Algoritmo Locação de Livro

algoritmo "locadora"

// Função :

// Autor :unopar

// Data : 16/11/2012

// Seção de Declarações

var

locacao, categoria, titulo: caractere

codigo, preco_da_locacao: real

soma: inteiro

op: logico

inicio

// Seção de Comandos

escreval ("Devolucao")

escreval ("Nome do usuario: ")

escreval ("Devolucão")

escreval ("=====================================")

escreval ("codigo")

escreval ("Codigo: ")

leia (codigo)

escreval ("Ttulo do Livro: ")

leia (titulo)

escreval ("Categoria: ")

leia (categoria)

Se categoria= 1 entao

escreval ("Preço da Locação: 15")

se categoria = 2 entao

escreval ("preço da locação: 55")

se categoria = 3 entao

escreval ("preço da locação: 30")

fimse

escreval ("Deseja continuar a locação?: ")

escreval (" [1]Sim [2]Não")

leia (op)

Enquanto op = 1 faca

escreval ("Codigo: ")

leia (codigo)

escreval ("Ttulo do Livro: ")

leia (titulo)

escreval ("Categoria: ")

leia (categoria)

Se op = 2 então

escreval ("Resumo da Locação")

escreval ("Total de locação da categoria 1: ")

escreval ("Total de locação da categoria 2: ")

escreval ("Total de locação da categoria 3: ")

fimse

4.2 TABELA VERDADE :

Se “Nossa locadora de livros’ não é uma empresa privada com fins lucrativos ou o primeiro computador da ‘Nossa locadora de livros’ foi adquirido em 1995, logo Maria Helena não é responsável pelo departamento financeiro da locadora.”

P Q R ~p ~r qv~p qv~r (~pvq)→(qv~r)

V V V F F V V V

V V F F V V V V

V F V F F F F V

V F F F V F V V

F V V V F V V V

F V F V V V V V

F F V V F V F F

F F F V V V V V

ALGORITMO CADASTRO DE LIVRO

algoritmo "semnome"

// Função :

// Autor :

// Data : 16/11/2012

// Seção de Declarações

var

op,op1,op2,op3,op4,op5:inteiro

nomeadmin,voltar:literal

user,livro:vetor [1..5,1..4] de literal

valor: inteiro

classificacao: vetor literal

genero:vetor literal

desconto: inteiro

inicio

//inicio cadastro livro

se op3=2 entao

escreval ("quantos livros deseja cadastrar 1 a 5 ")

leia (op3)

limpatela

fimse

se op3=1 entao

escreval ("----Cadastro 1° Livro-----")

escreval ("Digite o nome: ")

leia(livro[1,1])

escreval ("Digite o autor: ")

leia (livro[1,2])

escreval ("Digite o genero: ")

leia (livro[1,3])

escreval ("Digite o classificacao: ")

...

Baixar como (para membros premium)  txt (10.4 Kb)  
Continuar por mais 15 páginas »
Disponível apenas no TrabalhosGratuitos.com