TrabalhosGratuitos.com - Trabalhos, Monografias, Artigos, Exames, Resumos de livros, Dissertações
Pesquisar

Atps Algoritimo

Trabalho Escolar: Atps Algoritimo. Pesquise 791.000+ trabalhos acadêmicos

Por:   •  2/12/2012  •  1.289 Palavras (6 Páginas)  •  628 Visualizações

Página 1 de 6

1.0 Etapa 02

1.1 Passo 01

Considerem que nessa nova etapa do desafio será realizada uma nova solicitação do diretor da agência de turismo: que o aplicativo faça conversões de não só para o Real, mas da moeda y para a moeda x, das moedas sendo x e y uma já definidas e que serão indicadas pelo usuário. Ou seja, o usuário escolherá uma das opções para indicar qual é a moeda base e para qual deseja verificar a conversão. Por exemplo: N Reais equivalem a M Euros – Reais é a moeda base e Euros a moeda que se deseja saber a conversão.

A equipe deverá apresentar:

* o novo processamento a ser usado pelo algoritmo – mostrar os cálculos, justificando-os;

* apresentar o pseudocódigo do novo algoritmo.

Algoritmo – Conversor de Moeda

inicio

real: real<-1.00, dolarcnd<-1.64, euro<-2.27,dolarat<-1,63, valor, mbase;

inteiro: opcão1,opcão2;

escreva("<- Conversor de Moedas ->");

escreva("Informe a opcão da moeda base desejada para conversão");

ecreva("[1]R$ - [2]CND$ - [3]E$ - [4]US$(turismo)");

enquanto(opcão1<>1 e opcão1<>2 e opcão1<>3 e opcão1<>4 ); faça

escreva("Opcão: ");

leia(opcão1);

se opcão1 = 1 então

inicio

escreva("Você optou pela moeda Real!");

mbase<-real;

fim

senão

se opcão1 = 2 então

inicio

escreva("Você optou pela moeda Dolar Canadense!");

mbase<-dolarcnd;

fim

senão

se opcão1 = 3 então

inicio

escreva("Você optou pela moeda Euro!");

mbase<-euro;

fim

senão

se opcão1 = 4 então

inicio

escreva("Você optou pela moeda Dolar Americano[turismo]!");

mbase<-dolartur;

fim

senão

escreva("Opcão inválida, escolha outro opção!");

fimse;

fimse;

fimse;

fimse;

fimenquanto;

escreva("Informe o valor a converter: ");

leia(valor);

escreva("Informe para qual moeda se deseja converter!");

escreva("[1]R$ - [2]CND$ - [3]E$ - [4]US$")

escreva("Opcão: ");

leia(opcão2);

se opcão2 = 1 então

escreva("Você optou a conversão para Reais!");

escreva("O Resultado é: R$ ",(valor*mbase/real));

fim

senão

se opcao2 = 2 então

inicio

escreva("Você optou a conversão para Dolares Canadense!");

escreva("O Resultado é: CDN$ ",(valor*mbase/dolarcnd));

fim

senão

se opcao2 = 3 então

inicio

escreva("Você optou a conversão para Euros!");

escreva("O Resultado é: E$ ",(valor*mbase/euro));

fim

senão

se opcao2 = 4 então

escreva("Você optou a conversão para DOLAR AMERICANO!");

escreva("O Resultado é: E$ ",(valor*mbase/dolarat);

fimse;

fimse;

fimse;

fimse;

1.2 Passo 2 (Equipe)

Considerem que outra nova solicitação feita pelo diretor é que ao realizar a solicitação de conversão para Dólar Americano o aplicativo mostre o resultado para Turismo, Comercial e Paralelo, pois muitas vezes o usuário que é cliente da agência quer analisar conversões de valores gastos em cartão de crédito.

A apresentação da conversão deverá ser seguida da diferença em percentual entre o menor valor do Dólar Americano para os demais. Por exemplo, se o Dólar Americano Comercial estiver com cotação inferior, então deverá ser apresentada a diferença percentual do Comercial com o Turismo e do Comercial com o Paralelo.

Logo, para realizar esse Passo deverão apresentar:

* uma solução para o problema que considere:

o a conversão da moeda x para Dólar

...

Baixar como (para membros premium)  txt (10.5 Kb)  
Continuar por mais 5 páginas »
Disponível apenas no TrabalhosGratuitos.com