TrabalhosGratuitos.com - Trabalhos, Monografias, Artigos, Exames, Resumos de livros, Dissertações
Pesquisar

Trabalho de Lógica de Programação

Por:   •  3/1/2019  •  Trabalho acadêmico  •  1.196 Palavras (5 Páginas)  •  29 Visualizações

Página 1 de 5

var

a,b,c : real

inicio

// Seção de Comandos

escreva("entre com o valor de a: ")

leia(a)

escreva("entre com o valor de b: ")

leia(b)

escreva("entre com o valor de c: ")

leia(c)

         se (A<B+C) e (B<A+C) e (C<A+B) entao

         escreval("Estes valores formam um triangulo")

se (A=B) e (B=C) entao

                                escreva ("Triangulo Equilátero")

                        senao

                 se (A=B) ou (B=C) ou (A=C) entao

                                        escreva ("Triângulo Isósceles")

                                senao

                                        escreva ("Triangulo Escaleno")

                                fimse

                        fimse

senao

                        escreva ("Estes valores não formam um triângulo")

                fimse

fimalgoritmo

#include

#include

int main()

{

float A,B,C;

printf("Digite o tamanho do lado A de seu triangulo: ");

scanf("%f",&A);

printf("Digite o tamanho do lado B de seu triangulo: ");

scanf("%f",&);

printf("Digite o tamanho do lado C de seu triangulo: ");

scanf("%f",&C);

if(A < (B+C) & B < (A+C) & C < (A+B) /* verifica se é um triangulo */

{

if(A==B & B==C) /* Não é preciso tantos testes */

printf("O triangulo é Equilatero.");

else if(A==B||A==C||B==C)

printf("O triangulo é Isoceles.");

else

printf("Triângulo é Escaleno");

}

getch();

}

uda Algoritmo!Alguém entende?

Receber 3 valores numéricos, X, Y e Z, e verificar se esses valores podem corresponder aos lados de um triângulo. Em caso afirmativo, informar ao usuário se o triângulo é equilátero, isóscelos ou escaleno. Receber 3 valores numéricos em 3 variáveis, A, B e C, e trocar os valores entre as variáveis de forma que,... mostrar mais

 Melhor resposta:  algoritmo "Triângulo" 
var 
X, Y, Z, P:real 
inicio 
escreval("Para começar, você deve digitar os três lados do triângulo.") 
escreval("Vamos começar, digite o primeiro lado do triângulo:") 
leia(X) 
escreval("Digite o tamanho do segundo lado do triângulo:") 
leia(Y) 
escreval("Digite o tamanho do terceiro e último lado do triângulo:") 
leia(Z) 
se (X...se (X=Y) e (Z=Y) entao 
......escreval("É um triângulo Eqüilátero.") 
...senao 
......se (X=Y) ou (X=Z) ou (Y=Z) entao 
.........escreval("É um triângulo Isóceles.") 
......senao 
.........escreval("É um triângulo Escaleno.") 
......fimse 
...fimse 
senao 
...escreval("ERRO: O tamanho de um dos lados do triângulo supera a soma dos dois outros lados.")
...escreval("Portanto estes segmentos de reta não formam um triângulo.") 
fimse 
fimalgoritmo 

Obs.: obviamente substituindo os "." por " ".

...

Baixar como (para membros premium)  txt (4.9 Kb)   pdf (357.9 Kb)   docx (805.1 Kb)  
Continuar por mais 4 páginas »
Disponível apenas no TrabalhosGratuitos.com