TrabalhosGratuitos.com - Trabalhos, Monografias, Artigos, Exames, Resumos de livros, Dissertações
Pesquisar

Arquitetura De Computadores

Monografias: Arquitetura De Computadores. Pesquise 812.000+ trabalhos acadêmicos

Por:   •  31/5/2013  •  3.168 Palavras (13 Páginas)  •  672 Visualizações

Página 1 de 13

atividade 3

1) Para que a divisão entre 2 números possa ser realizada, o divisor não pode ser nulo (zero). Escreva um programa para ler 2 valores e imprimir o resultado da divisão do primeiro pelo segundo. OBS: O programa deve validar a leitura do segundo valor (que não deve ser nulo). Enquanto for fornecido um valor nulo a leitura deve ser repetida. Utilize a estrutura Enquanto/Faça na construção da repetição de validação.

em portugol

algoritmo "DIVISÃO"

// Função :dividir dois valores

// Autor :cilas brito

// Data : 20/04/2013

// Seção de Declarações

var

dividendo,divisor,resultado:real

inicio

// Seção de Comandos

enquanto divisor = 0 faca

escreva("DIGITE O PRIMEIRO NUMERO")

leia(dividendo)

escreva("DIGITE O SEGUNDO NUMERO")

leia(divisor)

fimenquanto

resultado<-dividendo/divisor

escreva("O RESULTADO DA DIVISÃO É:",resultado)

fimalgoritmo

em pascal

program DIVISÃO;

uses Crt;

{ Função :dividir dois valores}

{ Autor :cilas brito}

{ Data : 20/04/2013}

{ Seção de Declarações}

var

dividendo,divisor,resultado:real;

begin

{ Seção de Comandos}

while divisor = 0 do begin

write('DIGITE O PRIMEIRO NUMERO');

readln(dividendo);

write('DIGITE O SEGUNDO NUMERO');

readln(divisor);

end;

resultado:=dividendo/divisor;

write('O RESULTADO DA DIVISÃO É:',resultado);

end.

2) Altere a solução do exercício anterior para que seja impressa a mensagem Valor inválido! caso o segundo valor informado seja zero.

em portugol

algoritmo "DIVISÃO"

// Função :dividir dois valores

// Autor :cilas brito

// Data : 20/04/2013

// Seção de Declarações

var

dividendo,divisor,resultado:real

inicio

// Seção de Comandos

escreva("DIGITE O PRIMEIRO NUMERO")

leia(dividendo)

escreva("DIGITE O SEGUNDO NUMERO")

leia(divisor)

enquanto divisor = 0 faca

escreva("VALOR INVALIDO")

fimenquanto

resultado<-dividendo/divisor

escreva("O RESULTADO DA DIVISÃO É:",resultado)

fimalgoritmo

em pascal

program DIVISÃO;

uses Crt;

{ Função :dividir dois valores}

{ Autor :cilas brito}

{ Data : 20/04/2013}

{ Seção de Declarações}

var

dividendo,divisor,resultado:real;

begin

{ Seção de Comandos}

write('DIGITE O PRIMEIRO NUMERO');

readln(dividendo);

write('DIGITE O SEGUNDO NUMERO');

readln(divisor);

while divisor = 0 do begin

write('VALOR INVALIDO');

end;

resultado:=dividendo/divisor;

write('O RESULTADO DA DIVISÃO É:',resultado);

end.

3) Altere a solução do exercício 1 para que seja impressa a mensagem Outra Divisão? Enquanto o usuário desejar repetir o processo.

em portugol

algoritmo "DIVISÃO"

// Função :dividir dois valores

// Autor :cilas brito

// Data : 27/04/2013

// Seção de Declarações

var

dividendo,divisor,resultado:real

inicio

// Seção de Comandos

escreva("DIGITE O PROMEIRO NUMERO")

leia(dividendo)

escreva ("DIGITE O SEGUNDO NUMERO")

leia(divisor)

enquanto divisor = 0 faca

escreva("OUTRA DIVISÃO?")

...

Baixar como (para membros premium)  txt (19.6 Kb)  
Continuar por mais 12 páginas »
Disponível apenas no TrabalhosGratuitos.com