TrabalhosGratuitos.com - Trabalhos, Monografias, Artigos, Exames, Resumos de livros, Dissertações
Pesquisar

Trabalho apresentado ao Curso de Análise e Desenvolvimento de sistemas de UNOPAR – Universidade Norte do Paraná

Trabalho acadêmico: Trabalho apresentado ao Curso de Análise e Desenvolvimento de sistemas de UNOPAR – Universidade Norte do Paraná. Pesquise 793.000+ trabalhos acadêmicos

Por:   •  3/6/2013  •  Trabalho acadêmico  •  5.282 Palavras (22 Páginas)  •  569 Visualizações

Página 1 de 22

Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas

________________________________________

Universidade Norte do Paraná

________________________________________

________________________________________

SISTEMA DE ENSINO PRESENCIAL CONECTADO

ANÁLISE E DESENVOLVIMENTO DE SISTEMAS

lllllllllllllll

Produção Textual Interdisciplinar

Em Grupo

________________________________________

Araranguá

2011

Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistel

lllllllllllllll

Produção Textual Interdisciplinar

Em Grupo

Trabalho apresentado ao Curso Analise e Desenvolvimento de sistemas da UNOPAR – Universidade Norte do Paraná, para as disciplinas de Fundamentos de Lógica e Matemática Discreta, Seminário I, Organização de Computadores, Fundamentos da Administração da Informação, Linguagens e Técnicas de Programação I.

Professores: Denise Dias de Santana, Eliane Maria de Oliveira Araman, José Roberto Passini, Veronice de Freitas.

________________________________________

Sumário

1.1 Apresentação da locadora...................................................................06

1.2 Entidade e relacionamento no Br modelo............................................07

1.3 Ferramenta do visualg montamos uma lista............................................08

1.4 Tabelas modeladas no banco de dados DER.........................................11

1. INTRODUÇÃO

Este desenvolvimento tem a finalidade de demonstrar o cenário de uma locadora de livros no diagrama de atividades com o cenário atual da empresa e o proposto com as melhorias que vão ocorrer ao decorrer do trabalho com a implementação de um novo sistema e com novas funções e ferramentas de trabalho.

Proporcionando um atendimento melhor ao cliente que terá possibilidades que anteriormente não existia, tais como liberdade de escolha na data de entrega ou também locação.

1.1 No astah o diagrama de atividades com cenário atual da empresa e outro com um, cenário proposto, ou seja, com as melhorias sugeridas em um novo cenário após a implementação do sistema.

1.2 Cenários de entidade e relacionamento no br modelo

________________________________________UNOPAR VIRTUAL

1.3 Na ferramenta do visualg montamos uma lista tipo fila ordenadas para empréstimos de livro

algoritmo "locadora_livro"

// Função :

// Autor :

// Data : 07/06/2012

// Seção de Declarações

var

dia: vetor[1..10] de inteiro

livro: vetor[1..10] de caracter

I, J: inteiro

AUX: inteiro

AUX2: caracter

inicio

// Seção de Comandos

Para I de 1 ate 5 faca

Escreval("Posição ",I)

Escreva("Data de Empréstimo(Digite o AnoMesDia (AAAAmmDD)) : ")

Leia(dia[I])

Escreva("Nome do Livro: ")

Leia(livro[I])

Fimpara

Para J de 2 ate 5 faca

AUX <- dia[j]

AUX2 <- livro[j]

I <- J - 1

Enquanto (I > 0) E (dia[I] > AUX) faca

dia[I + 1] <- dia[I]

livro[I + 1] <- livro[I]

I <- I - 1

se (I = 0) entao

INTERROMPA

Fimse

Fimenquanto

dia[I + 1] <- AUX

livro[I + 1] <- AUX2

Fimpara

Escreval("Empréstimo Ordenado: ")

Para I de 1 ate 5 faca

Escreval("Data do Empréstimo: ",dia[I]," Nome do Livro: ",livro[I])

Fimpara

Fimalgoritmo

Execução do programa

Posição 1

Data de Empréstimo(Digite o AnoMesDia (AAAAmmDD)) : 20120601

Nome do Livro: borboletas na janela

Posição 2

Data de Empréstimo(Digite o AnoMesDia (AAAAmmDD)) : 20120605

Nome do Livro: origem da tragedia

Posição 3

Data de Empréstimo(Digite o AnoMesDia (AAAAmmDD)) : 20120530

Nome do Livro: meu livro cor de rosa

Posição 4

Data de Empréstimo(Digite

...

Baixar como (para membros premium)  txt (19.6 Kb)  
Continuar por mais 21 páginas »
Disponível apenas no TrabalhosGratuitos.com